Kali Linux GUI Modem Manager

Kali Linux GUI Modem Manager

The following article demonstrates the Kali Linux graphical user Interface Modem Manager installation commands, privilleges required and most likely output upon successful installation. Despite the use of Kali Linux for demonstration in this article, Ubuntu Linux, Debian Linux and some other distributions of Linux can follow the same command with variations being in the application package manager and privilleges required (Privillege elevation might be required depending on the Linux distribution and the type of user – the user privilleges).

 

 

To Install Modem Manager, run the following command inside terminal:

apt-get install modem-manager-gui

If you are not the root user, you will have to execute the above command with elevated privilleges using the prefix sudo which will require you to enter your password (when typing, the password keying in will not reflect on the terminal, so just type the correct password and hit Enter). The resulting command in terminal all-together will be:

sudo apt-get install modem-manager-gui

 

 

The Modem Manager has the following capabilities:

– Checking cellular signal strength
– Changing the cellular APN (Access Point Name) settings
– Receiving and managing SMS text messages
– Sending USSD requests
– Connecting/Disconnecting DATA connectivity
– Storing and resetting SIM card statistics on DATA usage

 

 

 

TERMINAL demonstration of command execution and results:

root@kali:~# apt-get install modem-manager-gui
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
libcodec2-0.8.1 libx265-176
Use ‘apt autoremove’ to remove them.
The following additional packages will be installed:
aspell enchant-2 libappindicator3-1 libaspell15 libenchant-2-2
libgtkspell3-3-0 libindicator3-7 modem-manager-gui-help
Suggested packages:
aspell-doc spellutils libenchant-2-voikko libindicate5 | libmessaging-menu0
The following NEW packages will be installed:
enchant-2 libappindicator3-1 libenchant-2-2 libgtkspell3-3-0 libindicator3-7
modem-manager-gui modem-manager-gui-help
The following packages will be upgraded:
aspell libaspell15
2 upgraded, 7 newly installed, 0 to remove and 1511 not upgraded.
Need to get 1,528 kB of archives.
After this operation, 7,935 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://kali.download/kali kali-rolling/main amd64 aspell amd64 0.60.8-1 [266 kB]
Get:2 http://kali.download/kali kali-rolling/main amd64 libaspell15 amd64 0.60.8-1 [352 kB]
Get:3 http://kali.download/kali kali-rolling/main amd64 libenchant-2-2 amd64 2.2.7+repack1-1 [50.2 kB]
Get:4 http://kali.download/kali kali-rolling/main amd64 enchant-2 amd64 2.2.7+repack1-1 [18.9 kB]
Get:5 http://kali.download/kali kali-rolling/main amd64 libindicator3-7 amd64 0.5.0-4 [52.9 kB]
Get:6 http://kali.download/kali kali-rolling/main amd64 libappindicator3-1 amd64 0.4.92-7 [53.5 kB]
Get:7 http://kali.download/kali kali-rolling/main amd64 libgtkspell3-3-0 amd64 3.0.10-1 [35.0 kB]
Get:8 http://kali.download/kali kali-rolling/main amd64 modem-manager-gui amd64 0.0.19.1-2 [373 kB]
Get:9 http://kali.download/kali kali-rolling/main amd64 modem-manager-gui-help all 0.0.19.1-2 [326 kB]
Fetched 1,528 kB in 4s (350 kB/s)
Reading changelogs… Done
(Reading database … 413681 files and directories currently installed.)
Preparing to unpack …/0-aspell_0.60.8-1_amd64.deb …
Unpacking aspell (0.60.8-1) over (0.60.7~20110707-6) …
Preparing to unpack …/1-libaspell15_0.60.8-1_amd64.deb …
Unpacking libaspell15:amd64 (0.60.8-1) over (0.60.7~20110707-6) …
Selecting previously unselected package libenchant-2-2:amd64.
Preparing to unpack …/2-libenchant-2-2_2.2.7+repack1-1_amd64.deb …
Unpacking libenchant-2-2:amd64 (2.2.7+repack1-1) …
Selecting previously unselected package enchant-2.
Preparing to unpack …/3-enchant-2_2.2.7+repack1-1_amd64.deb …
Unpacking enchant-2 (2.2.7+repack1-1) …
Selecting previously unselected package libindicator3-7:amd64.
Preparing to unpack …/4-libindicator3-7_0.5.0-4_amd64.deb …
Unpacking libindicator3-7:amd64 (0.5.0-4) …
Selecting previously unselected package libappindicator3-1:amd64.
Preparing to unpack …/5-libappindicator3-1_0.4.92-7_amd64.deb …
Unpacking libappindicator3-1:amd64 (0.4.92-7) …
Selecting previously unselected package libgtkspell3-3-0:amd64.
Preparing to unpack …/6-libgtkspell3-3-0_3.0.10-1_amd64.deb …
Unpacking libgtkspell3-3-0:amd64 (3.0.10-1) …
Selecting previously unselected package modem-manager-gui.
Preparing to unpack …/7-modem-manager-gui_0.0.19.1-2_amd64.deb …
Unpacking modem-manager-gui (0.0.19.1-2) …
Selecting previously unselected package modem-manager-gui-help.
Preparing to unpack …/8-modem-manager-gui-help_0.0.19.1-2_all.deb …
Unpacking modem-manager-gui-help (0.0.19.1-2) …
Setting up libaspell15:amd64 (0.60.8-1) …
Setting up libindicator3-7:amd64 (0.5.0-4) …
Setting up libappindicator3-1:amd64 (0.4.92-7) …
Setting up aspell (0.60.8-1) …
Setting up modem-manager-gui-help (0.0.19.1-2) …
Setting up libenchant-2-2:amd64 (2.2.7+repack1-1) …
Setting up libgtkspell3-3-0:amd64 (3.0.10-1) …
Setting up enchant-2 (2.2.7+repack1-1) …
Setting up modem-manager-gui (0.0.19.1-2) …
Processing triggers for gnome-menus (3.32.0-1) …
Processing triggers for libc-bin (2.29-9) …
Processing triggers for man-db (2.8.6.1-1) …
Processing triggers for desktop-file-utils (0.24-1) …
Processing triggers for mime-support (3.63) …
Processing triggers for hicolor-icon-theme (0.17-2) …
Processing triggers for dictionaries-common (1.28.1) …
root@kali:~#

 

 

 

 

Kali Linux GUI Modem Manager
Hacking | thetqweb